ERROR: Meta_Bus:audio: failed to get an audio bus allocated

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ERROR: Meta_Bus:audio: failed to get an audio bus allocated

Aegean Heart
Hello folks,

I am working on this project where I need to allocate several buses. However, I am getting the following error when running the code below:

48.do({arg item; ~busArray[item] = Bus.audio(s,2)})

ERROR: Meta_Bus:audio: failed to get an audio bus allocated. numChannels: 2 server: localhost

I've tried increasing the available buses but it doesn't seem to have any effect.
s.options.numAudioBusChannels = 2048; //doesn’t work

Running it on SC 3.8(latest release) and MacOs High Sierra 10.13 MacBook Pro (15, Mid 2015)

I’d really appreciate any tips
Thanks
A
_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Meta_Bus:audio: failed to get an audio bus allocated

daniel-mayer

Am 06.01.2018 um 00:42 schrieb [hidden email]:

>
> ERROR: Meta_Bus:audio: failed to get an audio bus allocated. numChannels: 2 server: localhost
>
> I've tried increasing the available buses but it doesn't seem to have any effect.
> s.options.numAudioBusChannels = 2048; //doesn’t work


Hi,

you have to reboot after setting server options.

Sincerly

Daniel

-----------------------------
www.daniel-mayer.at
-----------------------------


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/
Reply | Threaded
Open this post in threaded view
|

Re: ERROR: Meta_Bus:audio: failed to get an audio bus allocated

Aegean Heart
Thank you Daniel it works

best


> On 5 Jan 2018, at 23:58, [hidden email] wrote:
>
>
> Am 06.01.2018 um 00:42 schrieb [hidden email]:
>
>>
>> ERROR: Meta_Bus:audio: failed to get an audio bus allocated. numChannels: 2 server: localhost
>>
>> I've tried increasing the available buses but it doesn't seem to have any effect.
>> s.options.numAudioBusChannels = 2048; //doesn’t work
>
>
> Hi,
>
> you have to reboot after setting server options.
>
> Sincerly
>
> Daniel
>
> -----------------------------
> www.daniel-mayer.at
> -----------------------------
>
>
> _______________________________________________
> sc-users mailing list
>
> info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
> archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
> search: http://www.listarc.bham.ac.uk/lists/sc-users/search/


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/