Problem with Launchcontrol buttons and Modality Toolkit

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem with Launchcontrol buttons and Modality Toolkit

kflak
Hi list,

I just bought myself a Launchcontrol, and I’m having a bit of difficulty getting data from the pads using the Modality toolkit. The nav buttons all work fine, as do the knobs. However, when pressing the pads I get the message:

MKtl('lc') : unknown 'noteOn' element found at midiNum: 9,  midiChan 0.
Please add it to the description file. E.g. for a button:<bt>: (midiMsgType: 'noteOn', elementType: <'button'>, midiChan: 0, midiNum: 9, spec: <'midiBut'>, mode: <'push'>)


MKtl('lc') : unknown 'noteOff' element found at midiNum: 9,  midiChan 0.
Please add it to the description file. E.g. for a button:<bt>: (midiMsgType: 'noteOff', elementType: <'button'>, midiChan: 0, midiNum: 9, spec: <'midiBut'>, mode: <'push'>)

This seems a bit strange, as the desc file contains the lines:

(
key: \bt,
shared: ('elementType': 'pad', 'spec': 'midiNote', \ioType: \inout),
elements: ((9..12) ++ (25..28)).collect{|num, i|
(
key: (i+1).asSymbol, midiNum: num,
groupType: \noteOnOffBut,
shared: (
style: ( row: 2, column: i )
)
)
}

),

which, if I’m not mistaken, seems to address that specific issue. Am I missing something basic here? I’m a complete newbie to the world of MKtl

Best,
K
— — — —
Roosna & Flak, Contemporary Dance and Music

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with Launchcontrol buttons and Modality Toolkit

kflak
Bump!

Would be really grateful if anybody could help me out with this! I'm on SC 3.8, Mac OSX 10.11.6.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with Launchcontrol buttons and Modality Toolkit

patrick
Hi kflak,

I don't have time to test with my Launch Control right now. Looking at this quickly, my feeling is that this issue is due to the use of "\noteOnOfBut" in the MKtl description. The description may need to be updated. You should open an issue on github.

Cheers,
Patrick
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with Launchcontrol buttons and Modality Toolkit

kflak
Thanks for the reply, Patrick!
Will post an issue on github, as recommended.

Greets,
Kenneth
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem with Launchcontrol buttons and Modality Toolkit

alberto.decampo
fixed in modality now.

> On 09/03/2017, at 10:57 , kflak <[hidden email]> wrote:
>
> Thanks for the reply, Patrick!
> Will post an issue on github, as recommended.
>
> Greets,
> Kenneth
>
>
>
> --
> View this message in context: http://new-supercollider-mailing-lists-forums-use-these.2681727.n2.nabble.com/Problem-with-Launchcontrol-buttons-and-Modality-Toolkit-tp7630997p7631078.html
> Sent from the SuperCollider Users New (Use this!!!!) mailing list archive at Nabble.com.
>
> _______________________________________________
> sc-users mailing list
>
> info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
> archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
> search: http://www.listarc.bham.ac.uk/lists/sc-users/search/


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/
Loading...