Sc3plugins needs to be in system wide extensions dir?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Sc3plugins needs to be in system wide extensions dir?

Mattias Petersson
Hello,

Since upgrading to 3.9.0 i could suddenly no longer use the plugins. I downloaded the latest versions of SC3plugins and placed them in ~/Library/Application Support/SuperCollider/Extensions as usual. For some reason, I got "Class not defined” errors for all the plugins. This is strange because I have plenty of other class files that do work (within folders..) in that directory. I tried moving the plugin folder around and discovered that it works if I place it in /Library/Application Support/SuperCollider/Extensions instead.

I have never used that folder before so something must have changed, no? Or is it me as usual?

Thanks!
Mattias


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/
Reply | Threaded
Open this post in threaded view
|

Re: Sc3plugins needs to be in system wide extensions dir?

floriangrond
There have been changes in 3.9.1 to where the server searches for plugins i.e. in all subdirectories of Extensions and not only in a plugin folder under Extensions but these changes only affect supernova on OSX 

On Tuesday, February 6, 2018, <[hidden email]> wrote:
Hello,

Since upgrading to 3.9.0 i could suddenly no longer use the plugins. I downloaded the latest versions of SC3plugins and placed them in ~/Library/Application Support/SuperCollider/Extensions as usual. For some reason, I got "Class not defined” errors for all the plugins. This is strange because I have plenty of other class files that do work (within folders..) in that directory. I tried moving the plugin folder around and discovered that it works if I place it in /Library/Application Support/SuperCollider/Extensions instead.

I have never used that folder before so something must have changed, no? Or is it me as usual?

Thanks!
Mattias


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/


--

Reply | Threaded
Open this post in threaded view
|

Re: Sc3plugins needs to be in system wide extensions dir?

brianlheim


On Feb 6, 2018 9:03 AM, <[hidden email]> wrote:
There have been changes in 3.9.1 to where the server searches for plugins i.e. in all subdirectories of Extensions and not only in a plugin folder under Extensions but these changes only affect supernova on OSX 

This seems like a separate problem from that though. Mattias, which server program are you using?



On Tuesday, February 6, 2018, <[hidden email]> wrote:
Hello,

Since upgrading to 3.9.0 i could suddenly no longer use the plugins. I downloaded the latest versions of SC3plugins and placed them in ~/Library/Application Support/SuperCollider/Extensions as usual. For some reason, I got "Class not defined” errors for all the plugins. This is strange because I have plenty of other class files that do work (within folders..) in that directory. I tried moving the plugin folder around and discovered that it works if I place it in /Library/Application Support/SuperCollider/Extensions instead.

I have never used that folder before so something must have changed, no? Or is it me as usual?

Thanks!
Mattias


_______________________________________________
sc-users mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-users/
search: http://www.listarc.bham.ac.uk/lists/sc-users/search/


--


Reply | Threaded
Open this post in threaded view
|

Re: Sc3plugins needs to be in system wide extensions dir?

prko
I had experienced the same problem and solved as follows:
1. Erase all files and subfolders in  "~/Library/Application Support/SuperCollider/" except the file "startup.scd". You should remove Quarks folder as well.
2. Recopy the latest plugin for SC3.9 to "~/Library/Application Support/SuperCollider/Extensions".
3. Reinstall what you need from Quarks again.

I hope it helps you.

best