renaming unixCmd and CmdPeriod

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

renaming unixCmd and CmdPeriod

Nathan Ho
hi list,

there are two outstanding renames that i would like us to discuss:
unixCmd and CmdPeriod.

unixCmd is a pretty obviously terrible name since it is no longer
Unix-specific. previous discussion here:
http://new-supercollider-mailing-lists-forums-use-these.2681727.n2.nabble.com/quot-python-myscript-py-quot-unixCmd-td7637234.html

James suggested .asyncSystemCmd / .syncSystemCmd. i'm fine with those,
and also humbly suggest .subprocess and .runSubprocess (it's longer, but
i like making method and function names verbs in imperative form).

CmdPeriod is narrowly specific in three ways: it applies only to 1) Mac
users running the 2) IDE with 3) a default keybinding that can be
remapped. i suggest we give this an official name that describes what
it's supposed to do rather than how the user activates it. how about
"PanicButton" or "StopButton"?

in both cases it isn't difficult to make the name changes backward
compatible. (in the latter case, CmdPeriod relies on objects
implementing the .cmdPeriod method, and we can support both .panicButton
and .cmdPeriod.)


nathan

_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

brianlheim
> unixCmd is a pretty obviously terrible name since it is no longer Unix-specific. previous discussion here: http://new-supercollider-mailing-lists-forums-use-these.2681727.n2.nabble.com/quot-python-myscript-py-quot-unixCmd-td7637234.html

In case someone doesn't read that thread, I'll say again that I agree with renaming in this case.

> James suggested .asyncSystemCmd / .syncSystemCmd. i'm fine with those, and also humbly suggest .subprocess and .runSubprocess (it's longer, but i like making method and function names verbs in imperative form).

I am fine with either term (systemCmd vs subprocess). Tend a bit toward subprocess. But I would really prefer to have the methods explicitly named sync/async or some equivalent. It's not easy for me to remember which is which, and I also cannot tell from the names whether runSubprocess is supposed to be the sync or async version. I'll say preemptively that I don't want them wrapped into a single method with a flag; the difference between sync/async is too important to just be a binary flag, in this case, IMO.

> CmdPeriod is narrowly specific in three ways: it applies only to 1) Mac users running the 2) IDE with 3) a default keybinding that can be remapped. i suggest we give this an official name that describes what it's supposed to do rather than how the user activates it. how about "PanicButton" or "StopButton"?

Less convinced on this one (but I'm a Mac user running the IDE with the default keybindings, so go figure). I haven't seen many complaints about it, while I just saw one or two gripes about unixCmd this week on various channels.

-Brian

On Thu, Jan 4, 2018 at 12:36 PM, <[hidden email]> wrote:
hi list,

there are two outstanding renames that i would like us to discuss: unixCmd and CmdPeriod.

unixCmd is a pretty obviously terrible name since it is no longer Unix-specific. previous discussion here: http://new-supercollider-mailing-lists-forums-use-these.2681727.n2.nabble.com/quot-python-myscript-py-quot-unixCmd-td7637234.html

James suggested .asyncSystemCmd / .syncSystemCmd. i'm fine with those, and also humbly suggest .subprocess and .runSubprocess (it's longer, but i like making method and function names verbs in imperative form).

CmdPeriod is narrowly specific in three ways: it applies only to 1) Mac users running the 2) IDE with 3) a default keybinding that can be remapped. i suggest we give this an official name that describes what it's supposed to do rather than how the user activates it. how about "PanicButton" or "StopButton"?

in both cases it isn't difficult to make the name changes backward compatible. (in the latter case, CmdPeriod relies on objects implementing the .cmdPeriod method, and we can support both .panicButton and .cmdPeriod.)


nathan

_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/

i
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

i

On 4 Jan 2018, at 19:04, <[hidden email]> <[hidden email]> wrote:

> CmdPeriod is narrowly specific in three ways: it applies only to 1) Mac users running the 2) IDE with 3) a default keybinding that can be remapped. i suggest we give this an official name that describes what it's supposed to do rather than how the user activates it. how about "PanicButton" or "StopButton"?

Less convinced on this one (but I'm a Mac user running the IDE with the default keybindings, so go figure). I haven't seen many complaints about it, while I just saw one or two gripes about unixCmd this week on various channels.

Qt::CTRLPeriod? ;-)

Not so bothered either, but PanicButton or StopButton would at least be clearer in intent. With a longish deprecation wouldn’t be a crazy change I guess

S.

Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

julian.rohrhuber

> On 04.01.2018, at 20:06, [hidden email] wrote:
>
>
>> On 4 Jan 2018, at 19:04, <[hidden email]> <[hidden email]> wrote:
>>
>> > CmdPeriod is narrowly specific in three ways: it applies only to 1) Mac users running the 2) IDE with 3) a default keybinding that can be remapped. i suggest we give this an official name that describes what it's supposed to do rather than how the user activates it. how about "PanicButton" or "StopButton"?
>>
>> Less convinced on this one (but I'm a Mac user running the IDE with the default keybindings, so go figure). I haven't seen many complaints about it, while I just saw one or two gripes about unixCmd this week on various channels.
>
> Qt::CTRLPeriod? ;-)
>
> Not so bothered either, but PanicButton or StopButton would at least be clearer in intent. With a longish deprecation wouldn’t be a crazy change I guess

What about Stop ?

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

contact
In reply to this post by i
MuchBiggerButton?

On 04/01/18 20:06, [hidden email] wrote:

>
>> On 4 Jan 2018, at 19:04, <[hidden email]
>> <mailto:[hidden email]>> <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>> > CmdPeriod is narrowly specific in three ways: it applies only to 1)
>> Mac users running the 2) IDE with 3) a default keybinding that can be
>> remapped. i suggest we give this an official name that describes what
>> it's supposed to do rather than how the user activates it. how about
>> "PanicButton" or "StopButton"?
>>
>> Less convinced on this one (but I'm a Mac user running the IDE with
>> the default keybindings, so go figure). I haven't seen many complaints
>> about it, while I just saw one or two gripes about unixCmd this week
>> on various channels.
>
> Qt::CTRLPeriod? ;-)
>
> Not so bothered either, but PanicButton or StopButton would at least be
> clearer in intent. With a longish deprecation wouldn’t be a crazy change
> I guess
>
> S.
>

_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

Scott Carver
StopAll feels like a good name. References to "Button" are still too UI / implementation specific, Stop is probably too generic, and prevents usage of that name for anything moving forward. It could also be something like GlobalReset, since it's not REALLY stopping everything - it's also triggering ServerTree, which re-sets-up anything on the server that's supposed to always be running. CmdPeriod is supposed to ostensibly get you back to the state you were in when you first launched the server....

- S

On Thu, Jan 4, 2018 at 1:26 PM <[hidden email]> wrote:
MuchBiggerButton?

On 04/01/18 20:06, [hidden email] wrote:
>
>> On 4 Jan 2018, at 19:04, <[hidden email]
>> <mailto:[hidden email]>> <[hidden email]
>> <mailto:[hidden email]>> wrote:
>>
>> > CmdPeriod is narrowly specific in three ways: it applies only to 1)
>> Mac users running the 2) IDE with 3) a default keybinding that can be
>> remapped. i suggest we give this an official name that describes what
>> it's supposed to do rather than how the user activates it. how about
>> "PanicButton" or "StopButton"?
>>
>> Less convinced on this one (but I'm a Mac user running the IDE with
>> the default keybindings, so go figure). I haven't seen many complaints
>> about it, while I just saw one or two gripes about unixCmd this week
>> on various channels.
>
> Qt::CTRLPeriod? ;-)
>
> Not so bothered either, but PanicButton or StopButton would at least be
> clearer in intent. With a longish deprecation wouldn’t be a crazy change
> I guess
>
> S.
>

_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

Nathan Ho
On 2018-01-04 16:27, [hidden email] wrote:
> StopAll feels like a good name. References to "Button" are still too
> UI / implementation specific, Stop is probably too generic, and
> prevents usage of that name for anything moving forward. It could also
> be something like GlobalReset, since it's not REALLY stopping
> everything - it's also triggering ServerTree, which re-sets-up
> anything on the server that's supposed to always be running. CmdPeriod
> is supposed to ostensibly get you back to the state you were in when
> you first launched the server....

hi scott,

i like StopAll, although i prefer class names to be nouns. what about
StopAction? that would be grammatically consistent with its parent
class, AbstractSystemAction.


nathan

_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

Josh Parmenter
OMGMAKEITSTOPTHEPAINTHEPAINTHEPAIN!!!! is probably appropriate. Of course, sometimes that is the case and people are going for that.

Josh

> On Jan 4, 2018, at 4:44 PM, [hidden email] wrote:
>
> On 2018-01-04 16:27, [hidden email] wrote:
>> StopAll feels like a good name. References to "Button" are still too
>> UI / implementation specific, Stop is probably too generic, and
>> prevents usage of that name for anything moving forward. It could also
>> be something like GlobalReset, since it's not REALLY stopping
>> everything - it's also triggering ServerTree, which re-sets-up
>> anything on the server that's supposed to always be running. CmdPeriod
>> is supposed to ostensibly get you back to the state you were in when
>> you first launched the server....
>
> hi scott,
>
> i like StopAll, although i prefer class names to be nouns. what about StopAction? that would be grammatically consistent with its parent class, AbstractSystemAction.
>
>
> nathan
>
> _______________________________________________
> sc-dev mailing list
>
> info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
> archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
> search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/


_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/
Reply | Threaded
Open this post in threaded view
|

Re: renaming unixCmd and CmdPeriod

Kuivila, Ronald

Hi all,


Some responses from the peanut gallery:


I vote for sync/asyncSystemCmd, because the basic issue is that this is something

being done by the System, not SC.   (It is not guaranteed that the idea that 'subprocess' refers to an OS process will be clear to all users.)


About renaming CmdPeriod, I am agnostic.  

But I wonder  if CmdPeriod might be simply subsumed into Main.

( CmdPeriod's  'run' and 'hardRun'  methods are accessed via Main's 

'stop' and 'hardStop' which seems redundant and a bit fussy.)  


Pushing this a bit further, my understanding is that there is one and only one instance of Main, accessed via thisProcess.  If so, are there reasons not to have all of Main's interface be in the form of class methods?  

That would provide one stop shopping for a variety of configuration issues and allow users to write
'Main.showHelpBrowser' 
instead of the somewhat mysterious 
'thisProcess.showHelpBrowser'




RJK


From: [hidden email] <[hidden email]> on behalf of [hidden email] <[hidden email]>
Sent: Thursday, January 4, 2018 8:09:02 PM
To: [hidden email]
Subject: Re: [sc-dev] renaming unixCmd and CmdPeriod
 
OMGMAKEITSTOPTHEPAINTHEPAINTHEPAIN!!!! is probably appropriate. Of course, sometimes that is the case and people are going for that.

Josh

> On Jan 4, 2018, at 4:44 PM, [hidden email] wrote:
>
> On 2018-01-04 16:27, [hidden email] wrote:
>> StopAll feels like a good name. References to "Button" are still too
>> UI / implementation specific, Stop is probably too generic, and
>> prevents usage of that name for anything moving forward. It could also
>> be something like GlobalReset, since it's not REALLY stopping
>> everything - it's also triggering ServerTree, which re-sets-up
>> anything on the server that's supposed to always be running. CmdPeriod
>> is supposed to ostensibly get you back to the state you were in when
>> you first launched the server....
>
> hi scott,
>
> i like StopAll, although i prefer class names to be nouns. what about StopAction? that would be grammatically consistent with its parent class, AbstractSystemAction.
>
>
> nathan
>
> _______________________________________________
> sc-dev mailing list
>
> info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
> archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
> search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/


_______________________________________________
sc-dev mailing list

info (subscription, etc.): http://www.birmingham.ac.uk/facilities/ea-studios/research/supercollider/mailinglist.aspx
archive: http://www.listarc.bham.ac.uk/marchives/sc-dev/
search: http://www.listarc.bham.ac.uk/lists/sc-dev/search/